Mittens
 member, 2 posts
 bio pt 1
 bio pt 2
Fri 4 Oct 2019
at 05:03
Re: RPoL Design Update
Looking great so far!  Thumbs up for the bigger font and un-cluttered layout!

Dark theme is very important to me due to the eye strain that white theme causes.  This was the very fist thing I tried out.  It worked everywhere except the main page.  But logging out of rpol.net and re-logging r.rpol.net fixed that.  Yay!  Thanks again for these great improvements for the visually impaired!  Please keep it up!  <3
Zag24
 supporter, 600 posts
Mon 14 Oct 2019
at 03:54
Re: RPoL Design Update
I've been away from RPoL for a few years, and been back for about a month.  I've been using the new site since returning and I wanted to give it a good trial before commenting.

Generally, I like the clean lines.  I personally don't care much about responsiveness because I'm only on RPoL on full sized computers, but I do understand that not everyone is at their screens as much as I am.  I think you've done a great job of allowing for responsiveness without giving up much when it isn't needed.

One bit I do miss from the other site is how the controls stayed on the screen all the time.  If I'm scrolling through a thread on Community Chat and decide I'm not interested, I have to scroll back to the top of the screen to get to the Home for Forum buttons (if I'm a few screens in and the back button doesn't make sense).  I realize that having dedicated real estate like that is anathema to responsive design that will work on small screens.  I just wanted to make sure that the dissenting opinion is out there.  If the consensus is for androids and iPhones, then I'm happy to bow to the majority.
steelsmiter
 member, 2058 posts
 BESM, Fate, Indies, PBTA
 NO FREEFORM! NO d20!
Mon 14 Oct 2019
at 04:01
Re: RPoL Design Update
Zag24:
One bit I do miss from the other site is how the controls stayed on the screen all the time.  If I'm scrolling through a thread on Community Chat and decide I'm not interested, I have to scroll back to the top of the screen to get to the Home for Forum buttons (if I'm a few screens in and the back button doesn't make sense).

Same. I've seen other sites use a floating up/down arrow off to the side that vanishes after a moment of scrolling. I really like those.


Spoiler for Necessitated longer reply that was basically irrelevant: (Highlight or hover over the text to view)
And I suppose since I'm getting a warning about not quoting so much text for such a short reply I better go ahead and extend it a little by saying my favorite design I've seen in a while is Blue Moon Roleplaying (though I'm not especially happy with the blue color scheme). Not that it's relevant, but... ya know... a longer reply.

This message was last edited by the user at 04:02, Mon 14 Oct 2019.

MythZarya
 member, 30 posts
Mon 14 Oct 2019
at 07:40
Re: RPoL Design Update

Ditto on the sidebar.

On the original interface (within a game), the Menu bar is always visible no matter how far down the page I scroll. I frequently right-click on a Menu item at the top of the screen and open in a new tab, so that I can stay right where I'm at on the first tab/screen.

On the new interface this isn't possible. The Menu items aren't visible when I scroll down the page. I would prefer (as steelsmiter mentioned) a 'floating' or 'scrolling' sidebar.
Raddek
 supporter, 16 posts
Tue 15 Oct 2019
at 16:46
Re: RPoL Design Update
I'm sure it's on your list Jase, but all of the change portrait pages seem to have a fixed width in the responsive site that isn't lined up with the width of the actual 8x4 row of portraits.  It makes more of a difference on an actual computer where the portraits actually overlap the menus on the right side.  The site as viewed on a mobile device just seems to have odd coloring (half grey half white) since the menus are repositioned.
flakeytheleper
 member, 2 posts
Wed 30 Oct 2019
at 12:46
Re: RPoL Design Update
In reply to MythZarya (msg # 358):

I would love to have that right bar scroll as you move down the page.

Additionally, if this is possible, I would love to have the unread messages highlighted and made it so you automatically are placed at the location of your oldest unread post.
SunRuanEr
 subscriber, 165 posts
Sat 2 Nov 2019
at 18:33
Issue with new message warning before posting?
You know how there's the warning that comes up when you hit post if a new message has been posted to a thread (if one came up while you were in the writing window, so RPoL doesn't think you've seen it) that forces you to acknowledge it before you submit your post?

I've always gotten that on the old site, even when I preview my own post (which is good, because the most recent post in the thread isn't even viewable on the screen if the previewed post is of any decent length). On the responsive site, I am NOT getting that warning if I have previewed the post before hitting submit.
horus
 member, 919 posts
 Wayfarer of the
 Western Wastes
Tue 5 Nov 2019
at 07:07
Game Creation
Does anyone else have issues trying to create new games on the new site?

See:  https://r.rpol.net/display.cgi?gi=16&ti=2950&date=1572937505#bottom , please.
SunRuanEr
 subscriber, 175 posts
Sun 15 Dec 2019
at 19:31
'Preview As' bugs
Found a few bugs related to 'Preview As'.

When I preview a post as the posting character, and only as the posting character, everything works properly.

1) I have no option to preview the post as another character that I control that has access to whatever Group the thread that the post is being made is in. I have the option to preview the post as characters I control that do not have access to the Group, and as every other character regardless of their Group access.

2) If I preview a post as a character that I don't control (with or without access to the Group), the post immediately turns itself a PM sent to any character I do control that has access to the Group, INSTEAD of posting it in the proper thread location. WITHOUT any warning of the little 'private' tag appearing under the posting character's name in the upper lefthand during the preview.

2a) If I hit the lower 'Preview' option (the one down by 'Post Message') again after #2, the 'private' warning tag under the posting character's name returns, but it remains a PM that wants to be sent to the characters I control that have access to the Group.

2b) If I attempt to 'Preview As' again, with a character that I do not control (with or without access to the Group), it turns the post into a PM to every character that I do control, with or without access to the Group.

This message was last edited by the user at 19:33, Sun 15 Dec 2019.

SunRuanEr
 subscriber, 176 posts
Tue 17 Dec 2019
at 04:36
Private to Language Group not working?
Not sure if this is a known issue or not. I didn't recall seeing it.

Language groups (that appear scrambled to those without the language, clear to those with it) seem to be working on responsive.

Private TO Language Group seems to NOT be working on responsive. No indicator that there was a private line there that a character should be able to see, or anything - just nothing at all, when the private to language group is used.

It looks like it's being used properly to the writer, even when previewing as another character that should be able to read the language, but the line is entirely absent on the viewer's end once it's posted - and yes, I double-checked group and language access and all that.

This message was last edited by the user at 04:40, Tue 17 Dec 2019.

jase
 admin, 3738 posts
 Cogito, ergo procuro.
 Carpe stultus!
Tue 17 Dec 2019
at 13:00
Re: RPoL Design Update
To cut down on this message here's what I've fixed;

  • Added slight left/right margin to mobile view, did that about three months ago.
  • Images in descriptions are now lightboxes (also spotted that lightboxes didn't work in message previews so fixed that too).
  • Fixed game creation.
  • Fixed previewing as someone else making it a weird private message.
  • Fixed portrait selection (browsing and searching).


I've had a little break so here's hoping I actually fixed things!  (c;

More verbose answers for things I haven't fixed...

SunRuanEr:
Noticed a problem with viewing character descriptions that have pictures in them tonight when on a phone (or when the site is narrowed all the way down on a desktop). Actually, a pair of problems.

(Edit: This happens with both right- and left-aligned photos. At first I thought it was only the right ones, but alas, it isn't.)

Ah, there's the problem.  Couldn't replicate it at first until I saw the last bit.  What you're seeing is a byproduct of floating images.

The character portrait is floated left, floating another image will cause some weirdness.

Off the top of my head the only way I can think of easily fixing it would be to change the layout of the screen.  Break out the portrait into a larger "header" area.

o    o
    ..
\___/
Bob the Builder
- Player
- 123 posts
Main description starts here ..........

But that kind of gets away from the point of having the portrait there in the first place.

Otherwise the user-side fix would be to put some text first, enough to have the text go below the portrait at the widest view.



SunRuanEr:
You know how there's the warning that comes up when you hit post if a new message has been posted to a thread (if one came up while you were in the writing window, so RPoL doesn't think you've seen it) that forces you to acknowledge it before you submit your post?

I've always gotten that on the old site, even when I preview my own post (which is good, because the most recent post in the thread isn't even viewable on the screen if the previewed post is of any decent length). On the responsive site, I am NOT getting that warning if I have previewed the post before hitting submit.

I thought if you previewed (or posted) after another message had been added it gave you that warning but then it disappeared after.



Zag24:
One bit I do miss from the other site is how the controls stayed on the screen all the time.

I've seen a few around, invariably relying on javascript if I recall.  It (or a up/down arrow) is on the "refinement" to-do list.



SunRuanEr:
Found a few bugs related to 'Preview As'.

When I preview a post as the posting character, and only as the posting character, everything works properly.

1) I have no option to preview the post as another character that I control that has access to whatever Group the thread that the post is being made is in. I have the option to preview the post as characters I control that do not have access to the Group, and as every other character regardless of their Group access.

Can't see the point in needing to do this, none of your other characters should be in the list except those tagged as a player.


SunRuanEr:
Private TO Language Group seems to NOT be working on responsive. No indicator that there was a private line there that a character should be able to see, or anything - just nothing at all, when the private to language group is used.

I can't replicate that problem.  Are you using "group" in the address?  e.g. "Private to group Elvish"?

Also don't forget part of the notice when previewing as someone else -- As a player previewing as another all private/secret lines to groups will be hidden and all languages will be scrambled regardless of the recipient -- this is deliberate otherwise you could find out who's in the private groups.
SunRuanEr
 subscriber, 177 posts
Tue 17 Dec 2019
at 13:27
Re: RPoL Design Update
Thanks for the fixes, Jase! For the other stuff...

jase:
SunRuanEr:
You know how there's the warning that comes up when you hit post if a new message has been posted to a thread (if one came up while you were in the writing window, so RPoL doesn't think you've seen it) that forces you to acknowledge it before you submit your post?

I've always gotten that on the old site, even when I preview my own post (which is good, because the most recent post in the thread isn't even viewable on the screen if the previewed post is of any decent length). On the responsive site, I am NOT getting that warning if I have previewed the post before hitting submit.

I thought if you previewed (or posted) after another message had been added it gave you that warning but then it disappeared after.

I'm used to seeing the warning come up at the top of the screen when I preview a post, or go to add a post, and there's been a new post posted between the time that I opened the posting window and when I previewed/hit post. It -does- disappear after you acknowledge that the warning is there. The issue is that on responsive, the warning isn't coming up at all when you preview your post (it does come up if you go straight to 'post' without previewing, but if you preview before you post there's no indicator.)


quote:
SunRuanEr:
1) I have no option to preview the post as another character that I control that has access to whatever Group the thread that the post is being made is in. I have the option to preview the post as characters I control that do not have access to the Group, and as every other character regardless of their Group access.

Can't see the point in needing to do this, none of your other characters should be in the list except those tagged as a player.

There's not one, I just noticed the idiosyncrasy when checking to replicate the issue that was forcing posts to become PMs. Especially because the preview list included some of my controlled characters (tagged as player or otherwise) but not all of them. Wasn't sure if it was somehow related to the forced-PM issue, so I figured I'd mention it.

Specifically because I was being given the preview option for characters that didn't have access to the thread group where the post was being made (and ergo shouldn't be able to see it at all), but not for ones that did have access to the group being posted in. It just seemed... strange. Not an issue, though, since you fixed the funky forced-PM issue. :)

quote:
SunRuanEr:
Private TO Language Group seems to NOT be working on responsive. No indicator that there was a private line there that a character should be able to see, or anything - just nothing at all, when the private to language group is used.

I can't replicate that problem.  Are you using "group" in the address?  e.g. "Private to group Elvish"?


I'm using the 'Insert a Private Line > Private to group (language>' option from the drop-down selector. I don't trust myself to write those by hand!

If I use the 'The Language group' option, where text appears but is scrambled if you don't have the language, the entered text appears. If I use the 'Private to group <language>' option, that should only display to the characters that have the language, nothing appears at all for them even when it should. This is only on responsive, it works on live.

quote:
Also don't forget part of the notice when previewing as someone else -- As a player previewing as another all private/secret lines to groups will be hidden and all languages will be scrambled regardless of the recipient -- this is deliberate otherwise you could find out who's in the private groups.

Fair point, I had forgotten that part. :)

Point was, though, that there's no indicator to the author of the post that their intended recipients can't see the private lines. On their end, the 'Private to group <language>' text appears as it was written. It's just not showing up on the other end. (Which is totes working as intended, obviously, just clarifying that the borking is ONLY on the recipient's end) It's almost impossible to tell unless you have someone go 'hey, didn't you catch that I said this?' only to find that there's nothing there to catch. Or, in my case, my spouse wrote a post that I knew had some language lines in it that my character should have been able to read, but when I went to look at it later on my machine there were no visible language lines... so we started digging. I'm not sure why it won't replicate for you, because we can reproduce the error every time. (and can double-check on live to verify that over there, it's working properly)

This message was last edited by the user at 13:36, Tue 17 Dec 2019.

jase
 admin, 3739 posts
 Cogito, ergo procuro.
 Carpe stultus!
Tue 17 Dec 2019
at 23:13
Re: RPoL Design Update
Managed to replicate the private to group issue and then tracked down the bug.  Ironically the part that was hiding it when previewing as someone else was also hiding it whenever you were viewing it as well (unless you were a GM).

Will have to take a look at the others when I've got more time.

Thanks (to all!) for reporting all the bugs.  Clearly I can't catch 'em all!
SunRuanEr
 subscriber, 178 posts
Tue 17 Dec 2019
at 23:33
Re: RPoL Design Update
Yay, it's fixed! I was just running here to jump around excitedly about that!

Thanks a bundle, jase! :)
SunRuanEr
 subscriber, 198 posts
Sun 2 Feb 2020
at 01:04
Re: RPoL Design Update
Not sure if this has already been mentioned, but it seems that embedded links to Game Maps don't work across both live and responsive sites.

When an embedded direct link to a Game Map is posted using the live site, the embed of the link is broken if viewed on responsive. Copy-pasting the link takes me to the map on live, which is what I suspect is breaking the embed. Not sure if it breaks if done the other way 'round, too, or if embedded links to other things are broken as well. I just happened to notice it with the Game Maps. Non-embedded links work just fine.
Raddek
 supporter, 17 posts
Fri 21 Feb 2020
at 15:28
Re: RPoL Design Update
Something odd that I've noticed recently is that I'm getting Not Secure notifications on the https:// sites both for responsive and live sites.  It is only here and there:  for example the main page and my game page does not show the advisory as soon as I go into one of the internal threads or the dice roller it does.  This may just be a Chrome thing, as I don't seem to have the same problem on Safari, though I haven't tried Edge or any other browser.
theseeker
 member, 24 posts
Mon 24 Feb 2020
at 05:23
Re: RPoL Design Update
Copy/paste the address on the displayed page when that happens.  Guessing that it will be http:// instead of https://.  Likely some links still hanging around that have not been converted to https.  Most links on the site will be relative (no http or https prefix), and will just use the same as the page the link is on.  But if some link is using the full url, including http, then that page, AND all pages that it links to using relative urls will then become insecure.  So need to find the *first* page the notification occurs on.  Jase might be able to locate it using a global search across the source for the whole site, looking for `http:`.  But it might be hiding in some generated code that gets included.

Can be fixed somewhat globally by setting the server to automatically and silently convert all incoming http requests to https.
Raddek
 supporter, 19 posts
Sat 7 Mar 2020
at 03:23
Re: RPoL Design Update
Sorry, been a little bit since I checked this thread.  I took a look at the https: switching randomly to http: and it seems like that isn't the problem.

As an example:  my character details page is showing not secure with a web address of: https://r.rpol.net/usermodules/profile.cgi?gi=58029 (obviously you won't be able to get there)

Likewise, some of my game threads are showing not secure like the one here: https://r.rpol.net/display.cgi?gi=58029&ti=49&date=1583550054

Oddly though, it makes a difference as to whether or not I am logged in.  If I copy paste the web address logged out, it shows secure, but logged in it shows not secure with both chrome and safari.
theseeker
 member, 27 posts
Sat 7 Mar 2020
at 05:25
Re: RPoL Design Update
That description probably means that the pages reporting not secure contain content that is using an http: link.  Likely culprit is an image.  Do you have an embedded profile image?  If the link to that is http: instead of https:, the whole containing page is marked as not secure.  Though some browsers, some versions, would show a slightly different message for that case, saying something about 'partially' not secure.

If you can not see the actual link, some browser / web developer tools will let you see every connection made while loading a page, and show whether the connection was secure or not.  It could also be a css or javascript file that is being loaded with the page.  I don't think a tutorial on web developer tools is appropriate here though.  I use Firefox tools mostly.  Chrome (at least) has similar.
Raddek
 supporter, 20 posts
Sat 7 Mar 2020
at 12:53
Re: RPoL Design Update
Yup, you nailed it.  Thanks for the help.
SunRuanEr
 subscriber, 237 posts
Sat 4 Apr 2020
at 00:58
Re: RPoL Design Update
Not sure if it's a Known Issue or not (I don't recall seeing it, but it's been a while), but Updating language groups on responsive doesn't seem to be sticking. Like, you check the box to add the language to the character, and then go hit 'Update', but the update doesn't take and the language group doesn't get added. (Tried this several times, so I know it wasn't a case of misclicking.)

Works fine on live.
muriwo
 member, 97 posts
Sun 5 Apr 2020
at 10:05
Feature Request: Responsive Site: Browser Notifications
[Could not find any way to search if this has already been requested - if it has, apologies].

Request: r.rpol.net can activate Browser Notifications for new Posts/PMs.   The user would activate this in his Preferences menu... then the site would ask the browser, which would ask the user for permission to enable such notifications.
At a basic level of implementation, there would either be notifications... or not.    At a more advanced level, the Preferences could be more fine-grained, for instance:
 - New Post in a Game I peruse
 - New Post in a Game I GM
 - New PM
 - New Rmail

Reason: RPOL has had the option to give email notifications, for many years.   I switched it off eons ago because I already get far too many emails from non-RPOL sources, and these notifications just add to the burden.    Whereas a browser notification lets me know something is happening if I am on my computer.   If I am not, it doesn't hassle me.

N.B. I don't know how difficult this is to implement from a scripting point of view.  Given that the new responsive site is a "ground-up rewrite", I just though that this feature might be easier to implement there.
Skald
 moderator, 892 posts
 Whatever it is,
 I'm against it
Sun 5 Apr 2020
at 10:34
Feature Request: Responsive Site: Browser Notifications
Just a thought ... is what you're asking for in anyway similar to RSS feeds ?  The old site has them, and it seems they're available on the new responsive site too (I don't use them, so can't attest to whether they're up and running on responsive yet, but I don't know there would have been much of a change in that functionality betwixt old and new).

Help file: RPoL faqs (rssfeeds)

And you can find the codes under Preferences | View your personal feeds
muriwo
 member, 98 posts
Sun 5 Apr 2020
at 11:54
Feature Request: Responsive Site: Browser Notifications
Thanks Skald, I believe that could work.

I have added a Feed Reader extension with Browser Notification to my browser, and then added the RPOL RSS feed URL to that.   Will see how it goes... looks like it will work.

I believe that for all users, a direct notification capacity might still be easier.   But certainly, not a high priority.
Zag24
 supporter, 607 posts
Tue 7 Apr 2020
at 14:34
Feature Request: Responsive Site: Browser Notifications
A really minor feature request:  After performing "Mark all as read" in a forum, do a window.history.popState() so that the back button does not just leave you in the forum, but instead returns to Home.