vads
 member, 5 posts
Thu 14 Jan 2021
at 18:43
Unread flag, no new messages
I'm on the r.rpol site, but I think that the same issue may apply to the older version.

I keep seeing the new post red, but can't see any new posts even when there are only 17 or 55 posts in total.

I doubt it is an edited post because often th gm has logged off for the night and I'm the last post.

I searched back a year and didn't see any comments on this issue, so I apologize if I missed something.
tmagann
 member, 688 posts
Thu 14 Jan 2021
at 18:44
Unread flag, no new messages
In reply to vads (msg # 1):

It could be a post to a thread you aren't able to access.
bigbadron
 moderator, 15983 posts
 He's big, he's bad,
 but mostly he's Ron.
Thu 14 Jan 2021
at 18:49
Unread flag, no new messages
In reply to vads (msg # 1):

Do you access the site from different devices?  Switching to a second device without logging out of the site on the first one can sometimes mess up the cookies, and result in false positives on post indicators.
RanzarthPhx
 member, 41 posts
Thu 14 Jan 2021
at 19:10
Unread flag, no new messages
In reply to bigbadron (msg # 3):

This right here is likely the issue. Because I use my phone and PC and I don't logout each time this happens on the regular.
KairolVal
 member, 1 post
 Software Developer
 New Zealand
Thu 14 Jan 2021
at 19:22
Unread flag, no new messages
I access the site from home, phone, and sometimes from work.

I can confirm this is 100% a thing. I think that keeping track of what has or hasn't been read is stored on a per device basis for browser feedback, and on a server basis for the underlying rss and email notifications.

Could be mistaken though. I'm a coder, but not a coder for this site. :)
vads
 member, 6 posts
Thu 14 Jan 2021
at 21:20
Unread flag, no new messages
In reply to bigbadron (msg # 3):

Ah, yes.




Aaand No.  I leave a thread and it claims to be unread.

This message was last edited by the user at 00:57, Fri 15 Jan.

Starchaser
 member, 818 posts
 Shoda mo tsumoreba taibok
Fri 15 Jan 2021
at 07:43
Unread flag, no new messages
Try clearing your rpol cookies.

I've only had this issue if I use different browsers, again because of cookies.
nauthiz
 subscriber, 691 posts
Fri 15 Jan 2021
at 15:14
Unread flag, no new messages
The cookies thing works.  Using the "mark all as read" option for a game can also work and be slightly quicker and easier.
ladysharlyne
 subscriber, 2978 posts
 You get out of a game the
 effort you put in it !!
Mon 18 Jan 2021
at 17:25
Unread flag, no new messages
I'm having the same problem but the mark all as read clears them and then when yuo go out of the game and back in they are all lit up again, all threads???
nauthiz
 subscriber, 697 posts
Mon 18 Jan 2021
at 17:35
Unread flag, no new messages
If the "Mark all as read" doesn't work, then you have to clear your cookies to fix it from my experience.

You may still have unread flags once you log back in after clearing the cookies but reading or marking them as read should work properly after that.
Zag24
 supporter, 664 posts
Mon 18 Jan 2021
at 18:42
Unread flag, no new messages
I suspect that this is a problem caused by moving between the new and old sites.  Cookies from r.rpol.net won't override those from just rpol.net.
coded steve
 member, 23 posts
Wed 20 Jan 2021
at 10:51
Unread flag, no new messages
This is occurring for me as well, I get the unread indicator for messages in the rpol forums area. But no indicators on message threads in the games section.

Iíve tried the various suggestions in this thread but still have the same problem.
Skald
 moderator, 925 posts
 Whatever it is,
 I'm against it
Thu 21 Jan 2021
at 05:39
Unread flag, no new messages
Can definitely be a problem switching between the responsive site and the old site as there is some overlap in cookie settings (and yes, I've been caught by that too).  :>
nauthiz
 subscriber, 699 posts
Thu 21 Jan 2021
at 05:53
Unread flag, no new messages
coded steve:
This is occurring for me as well, I get the unread indicator for messages in the rpol forums area. But no indicators on message threads in the games section.

Iíve tried the various suggestions in this thread but still have the same problem.



I think this is a new version of old behavior.  It's happening to me as well.

I use the responsive site both on my desktop machine, and my phone, and switching between the two will cause confusion because the devices don't share cookies.

It used to be that I'd get the red number indicator on something new for a game I had last visited on the other device, then when I checked the game every thread in the game would have the New Message Comet/Fireball icon.

Now it seems the opposite happens, I'll check the game that's red, and no thread will have it despite there being new messages.  Not sure which is better but it's likely rooted in the same cookie issue that I've just learned to live with at this point.
jase
 admin, 3805 posts
 Cogito, ergo procuro.
 Carpe stultus!
Thu 21 Jan 2021
at 09:35
Unread flag, no new messages
As per the message in https://r.rpol.net/display.cgi?gi=36224&ti=834...

After letting it stew in the back of my mind for a few days I've now set the responsive and traditional site to share cookies.  This means you should see the exact same message read/unread over both sites.

Please relog one more time on the responsive site to make sure all the old cookies from the responsive site are cleared.  As always if you're switching browsers/machines it's recommend that you relog to sync up the cookies.

This message was last edited by the user at 13:33, Thu 21 Jan.

Zag24
 supporter, 665 posts
Thu 21 Jan 2021
at 13:20
Unread flag, no new messages
Haha!  I was coming here to tell you that I saw some weird behavior that was cleared up by deleting all my r.rpol.net cookies.

However, I see that the site is creating new ones.  I had thought from your note that it would not be creating any new r.rpol cookies.
jase
 admin, 3806 posts
 Cogito, ergo procuro.
 Carpe stultus!
Thu 21 Jan 2021
at 13:34
Unread flag, no new messages
The site will create cookies but the domain is ".rpol.net".
Zag24
 supporter, 666 posts
Thu 21 Jan 2021
at 14:43
Unread flag, no new messages
It is definitely still creating r.rpol.net cookies.  This is just after I deleted them all.

Edit:  I guess I'm not allowed to put images here, so just the link.

http://zag.net/images/r.rpol.net.cookies.png
jase
 admin, 3807 posts
 Cogito, ergo procuro.
 Carpe stultus!
Thu 21 Jan 2021
at 15:03
Unread flag, no new messages
That's just the timezone cookie (singular) that's set via javascript.  There's no uid, read, etc cookies.
Jobe00
 member, 310 posts
 Role-Playing
 Game Mechanic
Thu 21 Jan 2021
at 21:14
Unread flag, no new messages
I'm getting threads in game where I'm the last poster not marking as read after I post and go back to the game menu.
I'll hit the Mark All as Read which will clear them, but if I go the main page and then return, a post that I was last to post in is once more marked as Unread.
Zag24
 supporter, 668 posts
Fri 22 Jan 2021
at 00:18
Unread flag, no new messages
In reply to Jobe00 (msg # 20):

That's the problem I was having.  Clear your r.rpol.net cookies.  If you're using Chrome, you can do this by clicking on the padlock icon just to the left of the URL bar at the top of your window.
jase
 admin, 3808 posts
 Cogito, ergo procuro.
 Carpe stultus!
Sat 23 Jan 2021
at 00:26
Unread flag, no new messages
Indeed.  If you haven't use the relog option on the responsive site then you absolutely have to and if that doesn't help then manually clearing cookies is the next step.

On a largely related matter I went over the cookie routines yesterday comparing the cookies set and read/unread indicators in two different browsers side-by-side, one visiting rpol.net and the other r.rpol.net.  I did find one issue (with the responsive site) where stickied threads could be marked as read if you read something newer than it, which I've now fixed, but otherwise everything looks good and identical to rpol.net output.

So at this stage if there are issues I'm going to assume it's a local cookie related problem rather than a bug that I've authored.  (c;